KiWi's Commodore SX-64

KiWi's Commodore SX-64

SX-64 Fast Loader & Modul Fix

 10. Juli 2016  in SX-64 / C-64

Leider ist der SX-64 zum C-64 nicht ganz so Kompatibel wie gedacht. Einerseits laufen die beiden CIA’s des SX-64 mit 60Hz anstatt wie beim PAL C-64 mit 50Hz. Andererseits wurde der Tape-Port weggelassen, da man ja schon eine eingebaute Floppy hat – so die Vermutung.

Leider haben die Konstrukteure des SX-64 nicht nur den Anschluß der Datasette weg gespart, sie haben auch noch vergessen die entsprechenden Leitungen am CIA und am CPU mit Widerständen zu Bestücken. So haben die Signale einen undefinerten Zustand – sind also weder LOW noch HIGH. Dies betrifft FLAG am CIA UB3 als auch am Prozessor 6510 die Prozessorports P3 P4 und P5. Da FLAG jedoch noch mit dem Seriellen Bus verbunden ist (SRQIN) führt dies bei manchen Schnell-Lade-Routinen (Fastloadern) dazu das diese Abschmieren. Zum Glück gibt es eine sehr einfache Methode diesen fehenden 3.3kOhm Widerstand nachzurüsten:

sx-64-fast-loader-fix

Man lötet einfach einen 3.3kOhm Widerstand zwischen Pin 1 des Seriellen Busses und Pin4 des Tastaturanschlusses (+5V).  Danach funktionieren nicht nur sämtliche Fastloader sondern es gibt auch ein paar Module (z.b. ROBOTRON 2084) für den Expansionsport die ohne diese Modifikation Probleme verursachen. Als einer der ersten hat Ray Carlsen dies hier dokumentiert. Diese Modifikation sollte als auf gar keinen Fall im SX-64 fehlen !

0 Kommentare über “SX-64 Fast Loader & Modul Fix”

    Schreibe einen Kommentar

    Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.


    *